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Chapter 2
Getting Started with Mathcad

This chapter provides a quick introduction to computing with Mathc
and demonstrates a few more advanced features like iterative calcul
and two-dimensional plotting. After you read this chapter, you’ll hav
enough information to begin to solve your own problems in Mathca

The following sections make up this chapter:

The Mathcad workspace
Overview of menus and toolbars.

Regions
How equations, text, and graphics make up a worksheet; the mechanics
selecting, copying, moving, and deleting regions.

A simple calculation
Calculating with Mathcad.

Definitions and variables
Creating simple Mathcad equations.

Entering text
Adding notes and labels to a worksheet.

Iterative calculations
Using range variables to repeat an equation for several values.

Graphs
Building a simple two-dimensional plot.

Saving, printing, and exiting
The Save, Print, and Exit commands from the File menu.
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The Mathcad workspace

For information on system requirements and how to install Mathcad on your comp
see the instructions that accompanied your installation media.

When you start Mathcad, you’ll see a window like that shown in Figure 2-1. By def
the worksheet area is white. To select a different color, choose Color⇒Background from 
the Format menu.

Figure 2-1: Mathcad Professional with math and other toolbars displayed.

Each button in the Math toolbar , shown on the left side of the Mathcad window in 
Figure 2-1, opens another toolbar of operators or symbols. You can insert many
operators, Greek letters, and plots by clicking the buttons found on these toolbar

   Button Opens math toolbar...

Arithmetic —Common arithmetic operators.

Evaluation—Equal signs for evaluation and definition, 
Boolean expressions.

Graph—Various two- and three-dimensional plot types.

Matrix —Matrix and vector operators.
16  Chapter 2  Getting Started with Mathcad
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Calculus—Derivatives, integrals, limits, and iterated sums and produc

Programming—Programming constructs (Mathcad Professional only).

Greek—Greek letters.

Symbolic—Symbolic keywords.

The Standard toolbar is the strip of buttons shown just below the main menus in Figu
2-1:
 

Many menu commands can be accessed more quickly by clicking a button on th
Standard toolbar. 

The Formatting toolbar  is shown immediately below the Standard toolbar in Figu
2-1. This contains scrolling lists and buttons used to specify font characteristics 
equations and text.

Tip To learn what a button on any toolbar does, let the mouse pointer rest on the button momen
You’ll see a tooltip beside the pointer giving a brief description.

To conserve screen space, you can show or hide each toolbar individually by cho
the appropriate command from the View menu. You can also detach and drag a toolb
around your window. To do so, place the mouse pointer anywhere other than on a b
or a text box. Then press and hold down the mouse button and drag. You’ll find 
the Standard and Math toolbars rearrange themselves appropriately depending on
you drag them. The other toolbars, on the other hand, retain their shape no matter 
you drag them. And Mathcad remembers where you left your toolbars the next t
you open the application.

Tip The Standard and Formatting toolbars are customizable. To add and remove buttons from
of these toolbars, click with the right mouse button on the toolbar and choose Customize from 
the pop-up menu to bring up the Customize Toolbar dialog box. 
The Mathcad workspace 17
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Working with windows 

When you start Mathcad, you open up a window on a Mathcad worksheet. You can 
have as many worksheets open as your available system resources allow. This a
you to work on several worksheets at once by simply clicking the mouse in which
document window you want to work in. 

There are times when a Mathcad worksheet cannot be displayed in its entirety be
the window is too small. To bring unseen portions of a worksheet into view, you 

Q Make the window larger as you do in other Windows applications.

Q Choose Zoom from the View menu and choose a number smaller than 100%.

You can also use the scroll bars, mouse, and keystrokes to move around the Ma
window, as you can in your other Windows applications. When you move the mo
pointer and click the mouse button, for example, the cursor jumps from wherever it
to wherever you clicked. 

Tip Mathcad supports the Microsoft IntelliMouse and compatible pointing devices. Turning th
wheel scrolls the window one line vertically for each click of the wheel. When you press 
[Shift ] and turn the wheel, the window scrolls horizontally.

See “Arrow and movement keys” on page 351 in the Appendices for keystrokes 
move the cursor in the worksheet. If you are working with a longer worksheet, cho
Go to Page from the Edit  menu and enter the page number you want to go to in th
dialog box. When you click “OK,” Mathcad places the top of the page you specif
the top of the window.

Tip Mathcad supports standard Windows keystrokes for operations such as file opening ([Ctrl ]O]) 
saving ([Ctrl ]S]), printing ([Ctrl ]P), copying([Ctrl ]C]), and pasting ([Ctrl ]V]). Choose 
Preferences from the View menu and check “Use standard Windows shortcut keys” on the
General tab to enable all Windows shortcuts. Remove the check to use shortcut keys sup
in Mathcad 7.

Regions 

Mathcad lets you enter equations and text anywhere in the worksheet. Each equ
piece of text, or other element is a region. Mathcad creates an invisible rectangle to 
hold each region. A Mathcad worksheet is a collection of such regions. To start a
region in Mathcad: 
18  Chapter 2  Getting Started with Mathcad
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Q Click anywhere in a blank area of the 
worksheet. You see a small crosshair. 
Anything you type appears at the 
crosshair.

Q If the region you want to create is a math region, just start typing anywhere you
the crosshair. By default Mathcad understands what you type as mathematics
“A simple calculation” on page 21 for an example.

Q To create a text region, first choose Text Region from the Insert menu and then 
start typing. See “Entering text” on page 24 for an example.

In addition to equations and text, Mathcad supports a variety of plot regions. See
“Graphs” on page 27 for an example of inserting a two-dimensional plot. 

Tip Mathcad displays a box around any region you are currently working in. When you click ou
the region, the surrounding box disappears.

Selecting regions

To select a single region, simply click it. Mathcad shows a rectangle around the re

To select multiple regions:

Q Press and hold down the left mouse button to anchor one corner of the selec
rectangle.

Q Without letting go of the mouse button, move the mouse to enclose everything
want to select inside the selection rectangle.

Q Release the mouse button. Mathcad shows dashed rectangles around region
have selected.

Tip You can also select multiple regions anywhere in the worksheet by holding down the [Ctrl ] 
key while clicking. If you click one region and [Shift ]-click another, you select both regions
and all regions in between.

Moving and copying regions   

Once the regions are selected, you can move or copy them.

Moving regions   

You can move regions by dragging with the mouse or by using Cut and Paste.

To drag regions with the mouse: 

Q Select the regions as described in the previous section.
Regions 19
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Q Place the pointer on the border of any selected region. The pointer turns into a 
hand.

Q Press and hold down the mouse button.

Q Without letting go of the button, move the mouse. The rectangular outlines of
selected regions following the mouse pointer.

At this point, you can either drag the selected regions to another spot in the works
or you can drag them to another worksheet. To move the selected regions into an
worksheet, press and hold down the mouse button, drag the rectangular outlines
the destination worksheet, and release the mouse button.

To move the selected regions by using Cut and Paste:

Q Select the regions as described in the previous section.

Q Choose Cut  from the Edit  menu, or click  on the Standard toolbar. This delet
the selected regions and puts them on the Clipboard.

Q Click the mouse wherever you want the regions moved to. Make sure you’ve clic
in an empty space. You can click either someplace else in your worksheet or
different worksheet altogether. Make sure the cursor looks like a crosshair.

Q Choose Paste from the Edit  menu, or click  on the Standard toolbar. 

Copying regions

You copy regions by using the Copy and Paste commands:

Q Select the regions as described in “Selecting regions” on page 19.

Q Choose Copy from the Edit  menu, or click  on the Standard toolbar. This copie
the selected regions to the Clipboard.

Q Click the mouse wherever you want to place a copy of the regions. You can c
either someplace else in your worksheet or in a different worksheet altogether. M
sure you’ve clicked in an empty space. You should see the crosshair.

Q Choose Paste from the Edit  menu, or click  on the Standard toolbar. 

Tip If the regions you want to copy are coming from a locked area (see “Safeguarding an area
worksheet” on page 109) or an Electronic Book, you can copy them simply by dragging th
with the mouse into your worksheet.

Deleting regions   

To delete one or more regions:
20  Chapter 2  Getting Started with Mathcad
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Q Select the regions as described in “Selecting regions” on page 19.

Q Choose Cut from the Edit  menu, or click  on the Standard toolbar.

Choosing Cut removes the selected regions from your worksheet and puts them o
Clipboard. If you don’t want to disturb the contents of your Clipboard, or if you do
want to save the selected regions, choose Delete from the Edit  menu instead.

A simple calculation 

Although Mathcad can perform sophisticated mathematics, you can just as easil
it as a simple calculator. To try your first calculation, follow these steps:

Q Click anywhere in the worksheet. You see 
a small crosshair. Anything you type ap-
pears at the crosshair.

Q Type 15-8/104.5=  . When you type 

the equal sign or click  on the Evalu-
ation toolbar, Mathcad computes and 
shows the result.

This calculation demonstrates the way Mathcad works:

Q Mathcad shows equations as you might see them in a book or on a blackboa
expanded fully in two dimensions. Mathcad sizes fraction bars, brackets, and o
symbols to display equations the same way you would write them on paper.

Q Mathcad understands which operation to perform first. In this example, Mathc
knew to perform the division before the subtraction and displayed the equatio
accordingly.

Q As soon as you type the equal sign or click  on the Evaluation toolbar, Math
returns the result. Unless you specify otherwise, Mathcad processes each equ
as you enter it. See the section “Controlling calculation” in Chapter 8 to learn h
to change this.

Q As you type each operator (in this case, − and /  ), Mathcad shows a small rectangle
called a placeholder. Placeholders hold spaces open for numbers or expressions
yet typed. As soon as you type a number, it replaces the placeholder in the equ
The placeholder that appears at the end of the equation is used for unit conver
Its use is discussed in “Displaying units of results” on page 138.
A simple calculation 21
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Once an equation is on the screen, you can edit it by clicking in the appropriate 
and typing new letters, digits, or operators. You can type many operators and G
letters by clicking in the Math toolbars introduced in “The Mathcad workspace” on 
page 16. Chapter 4, “Working with Math,” explains in detail how to edit Mathcad
equations.

Definitions and variables 

Mathcad’s power and versatility quickly become apparent once you begin to use
variables and functions. By defining variables and functions, you can link equation
together and use intermediate results in further calculations.

The following examples show how to define and use several variables.

Defining variables 

To clear the previous equation and define a variable t, follow these steps:

Q Click in the equation you just typed and 
press [Space ] until the entire expression 
is held between the two editing lines. Then 
choose Cut from the Edit  menu or click 

 on the Standard toolbar. 

Q Now begin defining t. Type t  followed by 

a colon:  or click  on the Arithmetic 
toolbar. Mathcad shows the colon as the 
definition symbol := . 

Q Now begin defining t. Type t  followed by 

a colon:  or click  on the Arithmetic 
toolbar. Mathcad shows the colon as the 
definition symbol := .   Type 10  in the 

empty placeholder to complete the definition for t.

If you make a mistake, click on the equation and press [Space ] until the entire 
expression is between the two editing lines, just as you did earlier. Then delete i
choosing Cut from the Edit  menu. See Chapter 4, “Working with Math,” for other 
ways to correct or edit an expression.

These steps show the form for typing any definition: 

Q Type the variable name to be defined.
22  Chapter 2  Getting Started with Mathcad
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Q Type the colon key :  or click  on the Arithmetic toolbar to insert the definition
symbol. The examples that follow encourage you to use the colon key, since th
usually faster.

Q Type the value to be assigned to the variable. The value can be a single numb
in the example shown here, or a more complicated combination of numbers a
previously defined variables.

Mathcad worksheets read from top to bottom and left to right. Once you have def
a variable like t, you can compute with it anywhere below and to the right of the equation 
that defines it. 

Now enter another definition.

Q Press [↵]. This moves the crosshair below 
the first equation.

Q To define acc as –9.8, type: acc:–9.8 . 
Then press [↵] again. Mathcad shows the 
crosshair cursor below the last equation 
you entered.

Calculating results    

Now that the variables acc and t are defined, you can use them in other expression

Q Click the mouse a few lines below the two 
definitions. 

Q Type acc/2 [Space ]*t^2 . The caret 
symbol (̂ ) represents raising to a power, 
the asterisk (* ) is multiplication, and the 
slash (/ ) represents division.

Q Press the equal sign (=).

This equation calculates the distance traveled by a falling body in time t with acceler-

ation acc. When you enter the equation and press the equal sign (=), or click 
the Evaluation toolbar, Mathcad returns the result.

Mathcad updates results as soon as you make changes. For example, if you click 
10 on your screen and change it to some other number, Mathcad changes the re
soon as you press [↵] or click outside of the equation.
Definitions and variables 23
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Entering text 

Mathcad handles text as easily as it does equations, so you can make notes abo
calculations you are doing. 

Here’s how to enter some text:

Q Click in the blank space to the right of the 
equations you entered. You’ll see a small 
crosshair.

Q Choose Text Region form the Insert 
menu, or press "  (the double-quote key), 
to tell Mathcad that you’re about to enter 
some text. Mathcad changes the crosshair into a vertical line called the inser
point. Characters you type appear behind this line. A box surrounds the inser
point, indicating you are now in a text region. This box is called a text box. It gro
as you enter text.

Q Type Equations of motion . Math-
cad shows the text in the worksheet, next 
to the equations.

Tip If you click in blank space in the worksheet and start typing, which creates a math region,
Mathcad automatically converts the math region to a text region when you press [Space ].

To enter a second line of text, just press [↵] and continue typing:

Q Press [↵].

Q Then type for falling body under gravity.

Q Click in a different spot in the worksheet 
or press [Shift ][↵] to move out of the 
text region. The text box disappears and 
the cursor appears as a small crosshair.

Note Use [Ctrl ][Shift ][↵] to move out of the text region to a blank space in your worksheet.
you press [↵], Mathcad inserts a line break in the current text region instead.

You can set the width of a text region and change the font, size, and style of the t
it. For more information on how to do these things, see Chapter 5, “Working with Te
24  Chapter 2  Getting Started with Mathcad
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Iterative calculations 

Mathcad can do repeated or iterative calculations as easily as individual calculat
Mathcad uses a special variable called a range variable to perform iteration.

Range variables take on a range of values, such as all the integers from 0 to 10.
Whenever a range variable appears in a Mathcad equation, Mathcad calculates 
equation not just once, but once for each value of the range variable. 

This section describes how to use range variables to do iterative calculations.

Creating a range variable

To compute equations for a range of values, first create a range variable. In the pro
shown in “Calculating results” on page 23, for example, you can compute results 
range of values of t from 10 to 20 in steps of 1. To do so, follow these steps:

Q First, change t into a range variable by 
editing its definition. Click on the 10  in 
the equation t:=10 . The insertion point 
should be next to the 10 as shown on the right.

Q Type ,  11 . This tells Mathcad that the 
next number in the range will be 11.

Q Type ;  for the range variable operator, or 

click  on the Arithmetic toolbar, and 
then type the last number, 20 . This tells Mathcad that the last number in the rang
will be 20. Mathcad shows the range variable operator as a pair of dots.

Q Now click outside the equation for t. 
Mathcad begins to compute with t defined 
as a range variable. Since t now takes on 
eleven different values, there must also be 
eleven different answers. These are dis-
played in an output table as shown at right. 
You may have to resize your window or 
scroll down to see the whole table.

Defining a function

You can gain additional flexibility by defining functions. Here’s how to add a functi
definition to your worksheet:
Iterative calculations 25
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Q First delete the table. To do so, drag-select the entire region until you’ve encl
everything between the two editing lines. Then choose Cut from the Edit  menu or 

click  on the Standard toolbar. 

Q Now define the function d(t) by typing 
d(t):

Q Complete the definition by typing this ex-
pression: 1600+acc/

2[Space ]*t^2 [↵]

The definition you just typed defines a function. The function name is d, and the 
argument of the function is t. You can use this function to evaluate the above express
for different values of t. To do so, simply replace t with an appropriate number. For 
example:

Q To evaluate the function at a particular 
value, such as 3.5, type d(3.5)= . Math-
cad returns the correct value as shown at 
right.

Q To evaluate the function once for each 
value of the range variable t you defined 
earlier, click below the other equations 
and type d(t)= . As before, Mathcad 
shows a table of values, as shown at right.

Formatting a result 

You can set the display format for any number Mathcad calculates and displays.
means changing the number of decimal places shown, changing exponential no
to ordinary decimal notation, and so on.

For example, in the example above, the first two values,  and 
are in exponential (powers of 10) notation. Here’s how to change the table produ
above so that none of the numbers in it are displayed in exponential notation:

Q Click anywhere on the table with the mouse. 

Q Choose Result from the Format menu. You see the Result Format dialog box. Th
box contains settings that affect how results are displayed, including the numb
decimal places, the use of exponential notation, the radix, and so on.

1.11 103⋅ 1.007 103⋅
26  Chapter 2  Getting Started with Mathcad
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Q The default setting for 
Exponential Threshold is 
3. This means that only 
numbers greater than or 
equal to  are dis-
played in exponential no-
tation. Click the arrows to 
the right of the 3 to in-
crease the Exponential 
Threshold to 6.

Q Click “OK.” The table changes to reflect 
the new result format.

Note When you format a result, only the display of the result is affected. Mathcad maintains ful
precision internally.

Graphs 

Mathcad can show both two-dimensional Cartesian and polar graphs, contour pl
surface plots, and a variety of other three-dimensional graphs. These are all exa
of graph regions.

This section describes how to create a simple two-dimensional graph showing the p
calculated in the previous section.

Creating a graph 

To create an X-Y plot in Mathcad, click in blank space where you want the graph

appear and choose Graph⇒X-Y Plot  from the Insert menu or click  on the Graph
toolbar. An empty graph appears with placeholders on the x-axis and y-axis for the 

103
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expressions to be graphed. X-Y and polar plots are ordinarily driven by range varia
you define: Mathcad graphs one point for each value of the range variable used 
graph. In most cases you enter the range variable, or an expression depending 
range variable, on the x-axis of the plot. But the QuickPlot feature in Mathcad lets you 
plot expressions even when you don’t specify the range variable directly in the p

For example, here’s how to create a QuickPlot of the function d(t) defined in the 
previous section:

Q Position the crosshair and type d(t) . 
Make sure the editing lines remain dis-
played on the expression.

Q Now choose Graph⇒X-Y Plot  from the 

Insert menu, or click  on the Graph 
toolbar. Mathcad displays the frame of 
the graph.

Q Click anywhere outside the graph. Math-
cad calculates and graphs the points. A 
sample line appears under the “d(t).” This 
helps you identify the different curves 
when you plot more than one function. 
Unless you specify otherwise, Mathcad 
draws straight lines between the points 
and fills in the missing axis limits.

For detailed information on creating and formatting graphs, see Chapter 12, “2D P

Resizing a graph 

It’s easy to make a graph in Mathcad any size you want: just select the graph and s
it to the desired size.

To resize a graph, follow these steps:

Q Click the mouse just outside the graph and 
drag the mouse across the plot. A dashed 
selection rectangle emerges from the an-
chor point. 

Q When the selection rectangle just enclos-
es the graph, release the mouse button. 
The dashed rectangle turns into a solid 
rectangle with handles. 
28  Chapter 2  Getting Started with Mathcad
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Q Move the mouse pointer to any of the handles. It changes to a double-headed 

Q Press and hold down the mouse button. With the mouse button still pressed, 
the mouse. The graph is stretched in the direction of motion.

Q Once the graphics region is the right size, release the mouse button. 

Q Click outside the graph to deselect it.

Formatting a graph 

When you first create a graph it has default characteristics: numbered linear axes, n
grid lines, and points connected with solid lines. You can change these character
by formatting the graph, just as you earlier formatted a numerical result.

To format the graph created previously, follow these steps:

Q Choose Graph⇒X-Y Plot  from the 
Format menu, or double-click the 
graph to bring up the formatting dialog 
box. This box contains settings for all 
available plot format options. To learn 
more about these settings, see Chapter 
12, “2D Plots.”

Q Click the Traces tab. 

Q Click “trace 1” in the scrolling list un-
der “Legend Label.” Mathcad places 
the current settings for trace 1 in the 
boxes under the corresponding col-
umns of the scrolling list.

Q Click the arrow under the “Type” column to see a drop-down list of trace type
Select “bar” from this drop-down list.

Q Click “OK” to show the result of chang-
ing the setting. Mathcad shows the 
graph as a bar chart instead of connect-
ing the points with lines. Note that the 
sample line under the d(t) now has a bar 
on top of it.

Q Click outside the graph to deselect it.
Graphs 29
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Saving, printing, and exiting 

Once you’ve created a worksheet, you will probably want to save or print it.

Saving a worksheet 

To save a worksheet:

Q Choose Save from the File menu or click  on the Standard toolbar. If the file
has never been saved before, the Save As dialog box appears. Otherwise, Mathca
saves the file with no further prompting. 

Q Type the name of the file in the text box provided. To save to another folder, lo
the folder using the Save As dialog box.

By default Mathcad saves the file in Mathcad (MCD) format, but you have the option
of saving in other formats, such as RTF and HTML, as a template for future Mathcad 
worksheets, or in a format compatible with earlier Mathcad versions. For more 
information, see Chapter 7, “Worksheet Management.”

Printing

To print, choose Print from the File menu or click  on the Standard toolbar. To

preview the printed page, choose Print Preview from the File menu or click    on 
the Standard toolbar.

For more information on printing, see Chapter 7, “Worksheet Management.”

Exiting Mathcad 

When you’re done using Mathcad, choose Exit  from the File menu. Mathcad closes 
down all its windows and returns you to the Desktop. If you’ve made any change
your worksheets since the last time you saved, a dialog box appears asking if you
to discard or save your changes. If you have moved any toolbars, Mathcad remem
their locations for the next time you open the application.
30  Chapter 2  Getting Started with Mathcad
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